No internet connection
  1. Home
  2. Questions

Could Not Open Message Store: Login failed for user

By Dave @Dave5a2021-03-19 22:16:26.712Z

After creating database manually and running the SQL script to create tables, (See CREATE DATABASE failed (system error 3)) ThinkAutomation Studio Reports the Local Service is not running. Investigation Windows Application Logs, I found the warning 'Could not open Message Store: Login failed for user 'DOMAIN\COMPUTERNAME$'.. It continues to retry and eventually Errors out with 'Message Store database could not be opened. Service will stop.' (also in Windows application Log)

Since this might be a database login issue, I created a domain user ThinkAutomation5, granted it local computer rights to run as a service and gave it rights to the ThinkAutomation SQL Server database (remote instance), and assigned it to each of the three ThinkAutomation services Log On account, and restarted those services. No change other than the error message now refers to 'DOMAIN\ThinkAutomation5' instead of the computer name.

Any ideas on where to go from here?

  • 3 replies
  1. L
    Liam @liam2021-03-22 14:22:43.029Z

    What rights did you give to this user for access to the TA database?
    I'd recommend db_owner to get started, ensure that it is assigned against the TA database directly.

    My recommendation would be to use an SQL user rather than a domain or service account, simply because these are easier to work with.

    1. DDave @Dave5a2021-03-22 14:44:32.504Z

      Yes, I gave the user db_owner permissions to rule permissions issues out. I would have created a SQL user but didn't know where to specify the username/password since this error halts the loading of the TA Studio. I checked .config and .json files just in case but didn't see anything. Where would I set the username/password to use a SQL user?

      1. LLiam @liam2021-04-07 11:30:24.155Z2021-04-08 15:39:56.352Z

        Hi Dave

        The easiest way to do this will be to rebuild the connection string again.
        To do this go to File -> Server Settings -> Message Store -> Reconfigure