No internet connection
  1. Home
  2. Questions

Not able to start TA5 Service

By Sascha Feider @sfeider
    2022-01-17 16:53:23.120Z

    I just installed TA5 on our Windows server.
    When i try to start the TA5 Service, it stops immediately.

    This is the 2nd installed, we run the limited demo before, which worked fine (using the build in database).
    Then we uninstalled it, to get a clear installation using our MS SQL Server running on the same machine.

    Now we got the following errors:

    PSL.LOG

    2022-01-17:17:44:00 ThinkAutomation Professional Edition 5.0.760.2 Server Started
    2022-01-17:17:44:01 Using Microsoft SQL Server for Message Store.
    2022-01-17:17:44:01 From ThinkAutomationServer Index was outside the bounds of the array. Executing clsMetaData.SaveUser
    2022-01-17:17:44:01 From ThinkAutomationServer Index was outside the bounds of the array. Executing clsMetaData.Load
    2022-01-17:17:44:01 Could not load metadata:
    2022-01-17:17:44:01 ThinkAutomation 5.0.760.2 Server Stopped
    2022-01-17:17:44:01 End of session---------------------------------------------------------------
    

    What do we need to do now?
    Thanks for your help

    Sascha

    Solved in post #7, click to view
    • 6 replies
    1. Thomas Parker @mrtopkid
        2022-01-17 17:07:31.135Z

        Hi Sascha,

        Can you tell me if you've used the same administrator password on the 2nd install? I'm told the metadata will not load as the DB is encrypted.

        1. SSascha Feider @sfeider
            2022-01-17 17:16:22.108Z

            Unfortunately not, we forgot the demo password and so choosed to set up a clear instance.

            Is there a way to reset the metadata DB?

            1. ABenjamin @AutoBen
                2022-01-17 17:22:19.297Z

                Hi Sascha,

                To remedy this please follow the below steps;

                Uninstall ThinkAutomation 5

                Delete this Reg Key - Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ParkerSoft\

                Delete this folder - C:\ProgramData\Parker Software

                Delete this folder - C:\Program Files (x86)\ThinkAutomation

                Then reinstall ThinkAutomation 5

                1. SSascha Feider @sfeider
                    2022-01-17 20:17:09.120Z

                    I can't delete the whole Key / Folders, because there's a TA4 installation at the same site.

                    So i deleted:
                    Reg Key - Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ParkerSoft\ThinkAutomation\5
                    and Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ParkerSoft\

                    C:\ProgramData\Parker Software\ThinkAutomation.NET
                    (it looks like TA5 writes some Data to C:\ProgramData\Parker Software\ThinkAutomation too)

                    C:\Program Files\Thinkautomation
                    (v4 uses c:\Program Files(x86)\ThinkAutomationV4)

                    After this, reboot and next try:

                    1. Installation done
                    2. Setup Admin user done
                    3. Setup database connection done
                    4. Same error
                    2022-01-17:21:13:42 Using Microsoft SQL Server for Message Store.
                    2022-01-17:21:13:42 From ThinkAutomationServer Index was outside the bounds of the array. Executing clsMetaData.SaveUser
                    2022-01-17:21:13:42 From ThinkAutomationServer Index was outside the bounds of the array. Executing clsMetaData.Load
                    2022-01-17:21:13:42 Could not load metadata:
                    

                    TAv4 had 2 databases: messagestore and meta
                    TAv5 just creates a message store database, is this correct?

                    1. SSascha Feider @sfeider
                        2022-01-18 11:44:27.046Z

                        I installed the evaluation version on 2 other systems:
                        System 1 - using MS SQL DB
                        System 2 - using buildin Database

                        Both showing the following error message on creating the databases:

                        Could not create database tables. Der Index war außerhalb des Arraybereichs. FROM SetupDefaultUser
                        

                        (Index was outside the bounds of the array.)

                        Starting another try on clicking next, i get the message "Database already exists. Do you want to use it?" -> Yes
                        No further errors.
                        Startup screen is displayed, click on "Start" Thinkautomation Service starts end ends immediately

                2. L
                  In reply tosfeider:
                  Liam @liam
                    2022-02-01 07:47:10.336Z

                    This was resolved after discovering the password being used to create the TA user contained a semi-colon.

                    For the short-term, it is advised to avoid using a semi-colon in the TA password field.

                    Reply1 LikeSolution